Data conversion for MCAS-S

Overview

This document describes how to convert data for input into MCAS-S. Users should
refer to the MCAS-S User guide for more details on MCAS-S functionality and use.
The data conversion techniques are demonstrated in ArcGIS 9.3.1.

MCAS-S is a spatial software shell which can display spatial data but does not have
full GIS functionality. So data held within MCAS-S must conform in:

— spatial extent

— resolution, and

— projection.

The Toolkit data is currently in Albers projection with a datum of GDA94. There are
two sets of data at 1 km and 5 km resolution. The number of cells in the 1 km raster
data is 4009 columns and 3837 rows and in the 5 km raster data there are 802
columns by 767 rows.

The data are in a folder called Datapack_1k and Datapack_5k. Within these folders is
a Data folder which has the following sub-directories: Classified, Mask, Overlay and
Primary (see below).
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For simplicity, the data conversion process will be described for the 5 km dataset



Software and hardware requirements

System requirements

The minimum requirements for running MCAS-S is Windows NT, 2000, XP or Vista,
1GB RAM, 1Ghz CPU and 1GB of disk space for the program.

Software requirements

The recommended software for converting data for MCAS-S is ArcGIS - the current
version is 9.3.1 and requires the spatial analyst extension. Other software may be
used to convert data but are not described in this document.

Data formats
MCAS-S software is currently at version 2.1 and supports the following formats:
1. Raster for Primary and Mask data
a. ArcInfo Grids and Float

b. BIL
c. GeoTIFF
d. IDRISI

2. Polygon for Overlays
a. ESRI shapefiles

Data conversion

This section describes the data conversion process for Primary datasets, these are
used for analysis and must be in a raster format. The underlying principles of data
conversion are:

e datasets must be consistently captured and complete for the region of interest
— If data are missing for certain areas, the value of -9999 can be used as ‘no
data’
— If data are inconsistently captured then it is better to create separate
layers and merge them in MCAS-S

e consider whether the data should be input as Primary data, Overlays or
Masks; the same raster data can be used for both primary and mask layers

¢ while GIS data formats can generally support multiple attributes, MCAS-S can
only use one. The value field will be used by MCAS-S and so should contain
numbers that either directly represent the dataset (continuous) or are a class
code (categorical)

e data should be as “raw” as possible, if you wish to classify the data; then use
MCAS-S to do this. For example, slope data should be input as percent or
degrees rather than slope classes such as ‘flat’ or ‘steep’

e categorical data such as land use or vegetation types need to have a unique
numeric identifier and an accompanying text file given exactly the same name
as the dataset eg Primary/Land/globcover.txt and the format:
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10=Croplands

1l=lIrrigated croplands

12=Irrigated shrubs and trees

14=Rainfed croplands

16=Rainfed shrubs or trees

20=Mosaic cropland {50-70%)/Vegetation (grassland, shrubland, forest (20-50%)
30=Mosaic vegetation (grasland, shrubland, forest) 50-70%/Cropland {20-50%)
40=cClosed to open (>15%) broadleaved evergreen and,/or semi-deciduous forest {» 5m)
60=Closed {»40%) broadleaved forest {(=5m)

110=Mosaic forest/shrubland (50-70%)/Grassland 20-50%)

120=Mosaic grassland {50-70%)/Forest-shrubland (20-50%)

130=Closed to open (>15%) shrubland {<5m)

134=Deciduous broadleaved shrubland

135=Deciducus broadleaved closed shrubland

140=Closed to open [>15%) grassland

150=Sparse (>15%) vegatation (woody, shrub, grassland)

170=Closed(>40%) broadleavedsemi-deciduous forest regularly flooded - fresh water
180=Closed to open (>15) vegetation (grassland, shrub, woody) on regularly flooded or waterlogged soils - fresh, brackish or saline
190=artificial surfaces and associated areas (urban areas » 50%)

200=bare areas

210=waterbodies

220=permanent snow and ice

254 =unknown|

¢ minimise the number of processing steps as this will lead to resampling
errors.

Pre-processing

This section outlines how to convert data to the same format as the data provided in
Datapack_5k.

As examples, we have four datasets which require conversion:

Data Format Projection
placenames point GCS_WGS_1984
roads line GCS_GDA_1994
local government areas polygon Albers GDA 1994
globcover Raster (tif) Plate Caree WGS84
Set up a data processing folder structure, such as

- raw

- working

- final

Copy the input dataset into raw. Ensure the projection is defined and capture the
metadata into a tip file. An example of a tip file is shown below.

B roads.tip - WordPad
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Description: Roadlines from Topo 250k datasets

Custodian: G

Currency: Z006

Lineage:

TREL: http://www.ga.gov.aw/ mapspecs/ topographic/vws/sectionl. jap
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The tip file captures essential information about the dataset such as the name,
currency, units, custodian and links to the metadata. A lineage field describes how




the original data were processed. The tip file is created in Notepad or Word and
saved as a txt file with exactly the same name of the dataset and an extension . #p.
The first line of a tip file appears in MCAS-S when you hover the mouse over the
dataset; hence ensuring that the first line holds a useful description of the data.

1) Re-project the data

This section focuses on Primary data and outlines how to convert different datasets
to the correct raster format. The first step in data conversion is to project the data into
a common projection, in this case Albers Equal Area; datum GDA94. The ArcMAP
commands for re-projecting raster and vector data are as follows:

1A) Vector

In ArcCatalog select ArcToolbox>Data Management Tools>Projections and

Transformations>Feature>Project

* Project

Input Dataset or Feature Class

| placenames

Input Coordinate System (optional)

L

Oukput Dataset or Feature Class

| Wi projects\MCASIMRIA_toolkit_20104DatalWarkiplace_alb
Oukput Coordinate System

| GDA_1994_albers
Geographic Transformation (optional)

Save to working
directory

ICNENTY

Import projection from

oK Cancel

Datapack_5k/Data/
Primary/Agriculture/
beef _dse

le [+ |x |+

v

1B) Raster

In ArcCatalog select ArcToolbox>Data Management Tools>Projections and
Transformations>Raster>Project Rasterfunction

* Project Raster,

Input Raster

Registration Point {optional)

# Coordinate  Coordinate

|g|nhcnvar_DS ﬂ ﬂ
Input Coordinate System {optional)
| 2
DOutput Raster Dataset
| Wi\ projects\MCASINRM_toolkit_z010YData)workigloboover_alb ﬂ
Qutput Coordinate System
| GDa_1994_albers
|Gengraph|c Transformation (optional)
+
X
i
3
Resampling Techingue {optional)
[ mEAREST |
Oukput Cell Size {optional)
| Vil projectsiMCAS\MRM_toalkit_20104Datalworkimask_Sk

oK | Cancel

Environments...

Show Help >

Select Environments...
Set General Settings to
beef dse.
—  Output Coordinate
System
— Extent
Set Raster Analysis Settings to
beef dse.
— Cellsize
— Mask



5| Environment Settings _

¥'|Environment Settings

# General Settings
Current Warkspace

Scratch Workspace

Default Qutput 7 Value

& (&

Output Coordinate System

|As Specified Below j ==
| Goa_1994_albers
Output has Z Values
| Same As [npuk j
Cutput has M Yalues
| Same &s Inpuk ﬂ
¥ Mairtain fully qualiied field names
Extent
|As Specified Below ﬂ =
Top
-1009920, 430594
Left Right
-1887433,305799 2122566694201
Bottam
-4044920, 490594

Snap Rasker

M Resolution

3

oK | Cancel | Show Help == |

< ¥
Random number generatar

Seed Random Generator Type

| o |acmesg ~|

¥ Cartography Settings

¥ Coverage Settings

¥ Geodatabase Settings

¥ Geostatistical Analysis Settings

% Raster Analysis Settings
Cell Size

|ns Specified Below j =

| 5000

Mask
|V:\,projects\MCAS\NRM_tooIlqt_ZDDQ\Data\F\naI\,Datapack_Sk\Data1,Primary\.ﬂgriculture\,beef_ﬂ =

¥ Raster Storage Settings .

[s]4 | Cancel | Show Help == |

2) Convert the data to rasters

The next step is to convert the data into a raster; most of the tools for converting your
data are found in the Spatial Analyst toolbar which is found in ArcMap.

Open ArcMap and load the projected data.
Select the Spatial Analyst extension and Options... item and choose a template
dataset for setting the extent, resolution and mask (use beef_dseto set these).

Spatial Analyst t% Laver: | anr_rair

Distance b
Density...

Interpolate bo Raster b
Surface Analvsis b

Zell Statistics. ..

Meighborhood Statistics. . .
Zonal Statistics. ..

Zonal Histogram ...

Reclassify. ..
Raster Calculator, .,
Convert »

Opkions. ..

Options
General] Extent Cell Size ]
Analpsis cell size: |Same as Dataset "beef_dj
Cell gize: ’75000
MHumber of rows:; 767
MHumber of columns: a0z
(]9 Cancel




2A) Converting points

MCAS-S does not currently support point data and in order to create a raster layer,
some processing is required in ArcGIS. You need to consider how the data would be
used in MCAS-S, for example, you have a dataset of cities; do you want portray these
by location or proximity? If the location is more important, then you should convert the
points to rasters. If proximity is more important, then a distance function might be
preferable.

Points to rasters

Tool
Spatial Analyst>Convert>Features to Raster

Features to Raster, E|Pz|

Input Features: ||:||an:e_all:| ﬂ ==

Field: |OBIECTID =]
Cutput cell size: S000
OutpUL raster: | vilprojectsMCASINRM toolki E
ok |
Save as work/place_loc
Distance

A straight-line distance function can be used to convert sparse points such as water
points or grain silos to a raster.

Tool:
Spatial Analyst>Distance>Straight Line

Straight Line

Distance ko |p|au:e_a||:| ﬂ =
Maximum distance: Save as work/

dist_place
Cukput cell size: S0oa P

[ Create direction:

[ Create allacation:

=l

Qutput raster: | ¥iiprojectsiMCATINRM toolki o

(o] 4 | Cancel |




Interpolation

This is useful when you had a network of points such groundwater sampling sites.
This tool uses the Inverse-Distance weighted function and the output is a surface
raster.

Tool:
Spatial Analyst>Interpolate to Raster>Inverse Distance Weighted

Inverse Distance Weighted E| Pz|

Input points: ||:|Ia|:e_alb ﬂ g
7 value field: |CBIECTID |
Power: I—Z
Search radius bype: |'-."aria|:||e j
Search Radius Settings
Mumber of paints: lilz
PMairmurn distance: li
Use default settings
[ Use barrier polylines: | J J
Cutput cell size: I—E":":“:'
Output raster: |'u':Iprujects'l,MC.ﬁ.S'l,NRM_tuulld Save as work/idw_place
oK | Cancel |




2B) Converting lines
MCAS-S will accept line data as Overlays but not as Primary data.

Buffer
Create a polygon around the line features at a specified distance; this could be set
this to 250m.

ArcToolbox>Analysis Tools>Proximity>Buffer

* Buffer

Input Features

L

& &

| roads_alb
Qutput Feature Class
| WilprojectsiMCASINRM_toolkit_2010\Datalworkiroads_Buffer.shp

4 Distance [value or field]
&+ Linear unit

Save as work/road_buffer

L

| 250 Meters
" Field

Side Type (optional)

[ FLLL

End Type {optional)

| RoUND

Dissolve Type {optional)

[ nonE

Dissolve Field{s) {(optional)
OFi ~
OoeEcTID

OrFeatTYPE

O name .
Oaass

OFormaTION

Onrn

Osru

MFFaTRAI
<

L Lo Lo L

Distance
A straight-line distance
function can be used to convert lines such as rivers or roads to a distance raster.

oK | Cancel | Environments. .. | Show Help ==

Tool:
Spatial Analyst>Distance>Straight Line

Straight Line

Diskance to: |ru:uau:|s_a||:| ﬂ =

Maimum distance:
Cutput cell size: 000

| Create direction: |
[ Create allocation: |

Oubput raster: |in*:IprnjectSIMCﬁSINRM_tDD"d Ei-"l Save as work/dist_road

K, | Zancel |




It may be required to split roads into major (dual carriageway, principal) and minor
(secondary, minor and tracks) roads by selecting in Properties> Definition Query.

2C) Converting polygons

It should be remembered that Arc rasters uses a numeric attribute. If you do not have
one, this should first be created in ArcMap by opening the attribute table and adding
a field (from Options>Add field). Then select the field and populate it using the field
calculator (from right mouse button).

Tool:
Conversion Tools>To Raster>Feature to raster

Features to Raster

Input Features: |||;|a_a||:- j ==

This field should be numeric

Figld:
Cutput cell size: S000
Output raster: | ViiprojectsiMCASINRM toolki (5

(o] 4 | Cancel |

However, you may wish to have more control over the final output by using
Conversion Tools>To Raster>Polygon to Raster tool and select Cell assignment type
as Maximum Combined Area.

2D) Converting grids
The simplest way to resample data is to use the raster calculator. The Options item in

the Spatial Analyst menu sets the output parameters.
# Raster Calculator, @

Layers: Arithmetic Trigonometric
dist_place " 7| 8| 3 = | o | And sbs | Int Sin | ASin
digt_roads
lobcover 05
ﬁm / 4 B B > | w=| W Ceil | Float Cos | ACos
lga
1 2 3 < = Haor Floar |=hull Tan ATan
+ 1] . [ | Mot Logarithms Powers
Exp Log St
[globcover alb]
Exp2 Log2 Sqr
Expl0| Logll P

Ahbout Building E:-:pression$| Ewaluate | Cancel | <<‘

Furthermore, you can use the Raster Calculator to set ‘No data’ values to -9999 using
the con(isnull)) function:



# Raster Calculator @gl

Layers: Arithmetic Trigonometric
dist_place " 7| 8| 3 = | o | And sbs | Int Sin | ASin
digt_roads
lobcover 05
ﬁm / 4 B B > | w=| W Ceil | Float Cos | ACos
lga
1 2 3 < = Haor Floar |=hull Tan ATan
+ 1] . [ | Mot Logarithms Powers
- Exp Log St
confistll{[globcowver_alh]), -9998, [globeowver_alh])
Exp2 Log2 Sqr
Expl0| Logll P

Ahbout Building E:-:pression$| Ewaluate | Cancel | <<‘

The output of the Raster Calculator is a temporary raster that you will need to save
permanently by selecting the raster, right-click and select Data>Make Permanent.
Save to working.

The raster calculator uses nearest neighbour technique for resampling. This
technique is appropriate if the data is categorical. If the data is continuous, bilinear
interpolation or cubic convolution is preferred.

If you require more flexibility in resampling, you should also use the Resample tool
(in Data Management>Raster>Raster Processing>Resample). Here you can select
majority as well as bilinear or cubic.

3) Save the data

Finally copy the final data into the appropriate MCAS-S Primary data directories. For
example the dist_places dataset might go in the following folder: Datapack 5k/Data/
Primary/social. Alternatively, a new sub directory can be created and the dataset
saved there.

Local government area (LGA) data can be used as a mask so it should be copied to
Datapack_5k/Data/Mask.

Make sure to add processing information to the .tip file and save alongside the
dataset. The .txt file for categorical data should also be saved alongside the
associated dataset.

Help

The most common problems in converting the data are that the extent, resolution or
projection of the data in MCAS-S does not conform. If the dataset doesn’t show up in
the Primary, Overlay or Mask drop down menus, or is the wrong place on the
mapping window then the data have different extents, cell sizes or projections and
you will need to re-create the data.
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You should also check that each dataset contains the same number of pixels using
the Layer Properties - 1246 columns and 916 rows in the examples used here. The
origin should also be exactly the same for all datasets.

If when you open a saved project, you get a big red X instead of a data layer - this
usually means that you have moved a dataset, renamed it or the data has been
corrupted. If the dataset has changed names or moved you can navigate to it by right-
clicking and selecting Change Source... If the dataset has been deleted or corrupted,
you will need to re-create the data.

If MCAS-S slows down or freezes then you may have too much data. Try removing
some of the datasets from the window. Another reason may be that your data are in
floating point format, which makes the dataset very large; the solution is to convert
the data to integers. For example if you have elevation data, you may wish to create
integers to the nearest 1m. In Raster Calculator enter /int(elevation).

Any technical questions can be addressed to Lucy.Randall@brs.gov.au
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